升级FAQ

来自Moodle中文网
跳转至: 导航搜索

如何从1.9.x升级到2.7?[编辑]

1.x -> 1.9.19 -> 2.2.11 -> 2.7

(升级到下一分支之前最好先升级到最新的稳定版本,插件亦是如此;从早期版本升级通常也没问题,但无法确保不出问题。)

如何升级Moodle?是否只是覆盖文件?[编辑]

不要覆盖文件,有可能会引起奇怪的错误。操作之前请阅读升级文档。

收到消息:“升级已经在进行,请等待!”[编辑]

出现这一消息很可能是因为升级完成消息出现之前你刷新了页面。如果你极其肯定没有升级的进程(PHP和/或MySQL)在执行了,可以点击“!!!”,然后重启升级过程。

注意:如若点击了“!!!”或尝试从另一浏览器重启升级,那么数据库里的数据有可能已经损坏了。如若这真的发生了,需要还原数据库然后重启升级并等待升级完成——大型站点的升级过程有可能花费数小时。

是否可以同时升级到不止一个版本?[编辑]

只能从Moodle2.2升级到2.7。

只能从Moodle1.9之后(2.2之前)升级到2.2。

有关从Moodle先前版本(1.9之前)升级到1.9的信息可参见Moodle2.2的升级文档的“升级到多个版本”这一部分。

检测到混合的 Moodle 版本,升级不能继续[编辑]

Moodle 更新过程已暂停,因为在 Moodle 目录内检测到来自至少两个 Moodle 主版本的 PHP 脚本。 这将可能引发重大问题。如果要继续,您必须保证 Moodle 目录只包含一个版本的 Moodle 文件。

建议您采用如下方法清理您的 Moodle 目录:

  • 重命名当前的 Moodle 目录为“moodle_old”
  • 创建一个只包含来自标准 Moodle 下载软件包、Moodle CVS 或 GIT 仓库的文件的文件夹
  • 从“moodle_old”目录移动 config.php 文件和所有非标准插件到新 Moodle 目录

当您有了纯净的 Moodle 目录,刷新页面继续 Moodle 更新进程。

这个警告一般是由解压标准 Moodle 软件包覆盖到旧版本的 Moodle 引发的。虽然这样做小的升级是可以的,但是一定不要这样升级主版本。

这个警告也可能由使用 GIT 仓库时的一次不完整的校验或更新操作引发的。如果是这样,您可能只需要等待操作完成,或者运行适当的清理命令并且重新执行原操作。

您可以在 http://docs.moodle.org/29/zh_cn/Upgrading 的升级文档中找到更多信息

另请参阅[编辑]